Dienstag, 17. August 2010

Multicast - Sparse-Mode - Static RP - Beispielkonfiguration


Topology

#R1#

R1#sh ip int brief | excl unassig
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.0.0.1        YES manual up                    up      
Loopback0                  1.1.1.1         YES manual up                    up      
R1#
R1#sh run | incl multicast
R1#
R1#sh ip route | incl 2.2.2.2
O       2.2.2.2 [110/5] via 10.0.0.2, 00:48:08, FastEthernet0/0
R1#
R1#sh run int fa 0/0
!
interface FastEthernet0/0
 ip address 10.0.0.1 255.255.255.252
 duplex auto
 speed auto

R1#sh run int lo0   
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
R1#

#SW1

SW1#sh ip int brief | excl unassi
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/1        10.0.0.2        YES manual up                    up      
FastEthernet0/5        10.0.0.5        YES manual up                    up      
FastEthernet0/19       10.0.0.13       YES manual up                    up      
SW1#
SW1#sh run int fa 0/1
!
interface FastEthernet0/1
 no switchport
 ip address 10.0.0.2 255.255.255.252
 ip pim sparse-mode

SW1#sh run int fa 0/5
!
interface FastEthernet0/5
 no switchport
 ip address 10.0.0.5 255.255.255.252
 ip pim sparse-mode

SW1#sh run int fa 0/19
!
interface FastEthernet0/19
 no switchport
 ip address 10.0.0.13 255.255.255.252
 ip pim sparse-mode

SW1#
SW1#sh ip mroute 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.0.0.1), 00:06:47/stopped, RP 5.5.5.5, flags: SPF
  Incoming interface: FastEthernet0/5, RPF nbr 10.0.0.6
  Outgoing interface list: Null

(10.0.0.1, 239.0.0.1), 00:02:09/00:01:27, flags: FT
  Incoming interface: FastEthernet0/1, RPF nbr 0.0.0.0, Registering
  Outgoing interface list:
    FastEthernet0/19, Forward/Sparse, 00:02:09/00:02:50, H
    FastEthernet0/5, Forward/Sparse, 00:00:44/00:03:19, H

(*, 224.0.1.40), 01:33:57/00:02:04, RP 5.5.5.5, flags: SJCL
  Incoming interface: FastEthernet0/5, RPF nbr 10.0.0.6
  Outgoing interface list:
    FastEthernet0/1, Forward/Sparse, 01:33:57/00:02:04

SW1#
SW1#sh run | incl rp
ip pim rp-address 5.5.5.5
SW1#sh ip pim rp map
PIM Group-to-RP Mappings

Group(s): 224.0.0.0/4, Static
    RP: 5.5.5.5 (?)
SW1#sh ip pim neigh
PIM Neighbor Table
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
10.0.0.14         FastEthernet0/19         01:16:25/00:01:35 v2    1 / DR S
10.0.0.6          FastEthernet0/5          00:02:08/00:01:37 v2    1 / DR S
SW1#
SW1#sh run
!
ip routing
!
ip multicast-routing 
!
interface FastEthernet0/1
 no switchport
 ip address 10.0.0.2 255.255.255.252
 ip pim sparse-mode
!
interface FastEthernet0/5
 no switchport
 ip address 10.0.0.5 255.255.255.252
 ip pim sparse-mode
!
interface FastEthernet0/19
 no switchport
 ip address 10.0.0.13 255.255.255.252
 ip pim sparse-mode
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
!
ip pim rp-address 5.5.5.5
!
SW1#  


#R5#

R5#sh ip int brief | excl unassi
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.0.0.6        YES manual up                    up      
FastEthernet0/1            10.0.0.9        YES manual up                    up      
Loopback0                  5.5.5.5         YES manual up                    up      
R5#
R5#sh run int fa 0/0
!
interface FastEthernet0/0
 ip address 10.0.0.6 255.255.255.252
 ip pim sparse-mode
 duplex auto
 speed auto
end

R5#sh run int fa 0/1
!
interface FastEthernet0/1
 ip address 10.0.0.9 255.255.255.252
 ip pim sparse-mode
 duplex auto
 speed auto
!
R5#sh run int lo0   
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
 ip pim sparse-mode
!
R5#sh ip mroute 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.0.0.1), 02:13:57/00:03:27, RP 5.5.5.5, flags: S
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/1, Forward/Sparse, 01:45:04/00:03:27

(10.0.0.1, 239.0.0.1), 00:00:07/00:02:52, flags: 
  Incoming interface: FastEthernet0/0, RPF nbr 10.0.0.5
  Outgoing interface list:
    FastEthernet0/1, Forward/Sparse, 00:00:07/00:03:27

(*, 224.0.1.40), 02:49:50/00:02:33, RP 5.5.5.5, flags: SJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/0, Forward/Sparse, 00:05:32/00:02:54
    FastEthernet0/1, Forward/Sparse, 02:46:48/00:02:34
    Loopback0, Forward/Sparse, 02:49:50/00:02:33

R5#
R5#sh run | incl rp
ip pim rp-address 5.5.5.5
R5#sh ip pim rp map
PIM Group-to-RP Mappings

Group(s): 224.0.0.0/4, Static
    RP: 5.5.5.5 (?)
R5#sh ip pim nei
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      S - State Refresh Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
10.0.0.5          FastEthernet0/0          00:07:21/00:01:19 v2    1 / S
10.0.0.10         FastEthernet0/1          01:26:35/00:01:18 v2    1 / DR S
R5#
R5#sh run
!
ip cef
ip multicast-routing 
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
 ip pim sparse-mode
!         
interface FastEthernet0/0
 ip address 10.0.0.6 255.255.255.252
 ip pim sparse-mode
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.0.0.9 255.255.255.252
 ip pim sparse-mode
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
!
ip pim rp-address 5.5.5.5
!
R5# 

#SW3#

SW3#sh ip int brief | excl una
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/5        10.0.0.10       YES manual up                    up      
FastEthernet0/19       10.0.0.18       YES manual up                    up      
SW3#
SW3#sh run int fa 0/5
Building configuration...

Current configuration : 130 bytes
!
interface FastEthernet0/5
 no switchport
 ip address 10.0.0.10 255.255.255.252
 ip pim sparse-mode
 end

SW3#sh run int fa 0/19
Building configuration...

Current configuration : 107 bytes
!
interface FastEthernet0/19
 no switchport
 ip address 10.0.0.18 255.255.255.252
 ip pim sparse-mode
end

SW3#
SW3#sh ip mroute 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.0.0.1), 01:49:10/00:02:43, RP 5.5.5.5, flags: S
  Incoming interface: FastEthernet0/5, RPF nbr 10.0.0.9
  Outgoing interface list:
    FastEthernet0/19, Forward/Sparse, 01:49:10/00:02:43, H, A

(10.0.0.1, 239.0.0.1), 00:04:04/00:02:13, flags: PR
  Incoming interface: FastEthernet0/5, RPF nbr 10.0.0.9
  Outgoing interface list: Null

(*, 224.0.1.40), 01:56:47/00:03:27, RP 5.5.5.5, flags: SJCL
  Incoming interface: FastEthernet0/5, RPF nbr 10.0.0.9
  Outgoing interface list:
    FastEthernet0/19, Forward/Sparse, 01:56:48/00:03:27

SW3#
SW3#sh run | incl rp
ip pim rp-address 5.5.5.5
SW3#sh ip pim rp map
PIM Group-to-RP Mappings

Group(s): 224.0.0.0/4, Static
    RP: 5.5.5.5 (?)
SW3#sh ip pim nei
PIM Neighbor Table
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
10.0.0.17         FastEthernet0/19         03:01:34/00:01:26 v2    1 / S
10.0.0.9          FastEthernet0/5          01:30:18/00:01:29 v2    1 / S
SW3#
SW3#sh run       
!
ip routing
!
ip multicast-routing 
!
interface FastEthernet0/5
 no switchport
 ip address 10.0.0.10 255.255.255.252
 ip pim sparse-mode
!
interface FastEthernet0/19
 no switchport
 ip address 10.0.0.18 255.255.255.252
 ip pim sparse-mode
!
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
!
ip pim rp-address 5.5.5.5
!

SW3#       


#SW4#

SW4#sh ip int brief | excl unassi
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/13       10.0.0.14       YES manual up                    up      
FastEthernet0/16       10.0.0.21       YES manual up                    up      
FastEthernet0/19       10.0.0.17       YES manual up                    up      
SW4#
SW4#sh run int fa 0/13
!
interface FastEthernet0/13
 no switchport
 ip address 10.0.0.14 255.255.255.252
 ip pim sparse-mode
end

SW4#sh run int fa 0/16
!
interface FastEthernet0/16
 no switchport
 ip address 10.0.0.21 255.255.255.252
 ip pim sparse-mode
!
SW4#sh run int fa 0/19
!
interface FastEthernet0/19
 no switchport
 ip address 10.0.0.17 255.255.255.252
 ip pim sparse-mode
end

SW4#
SW4#sh ip mroute 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.0.0.1), 01:53:04/00:02:54, RP 5.5.5.5, flags: S
  Incoming interface: FastEthernet0/19, RPF nbr 10.0.0.18
  Outgoing interface list:
    FastEthernet0/16, Forward/Sparse, 01:53:04/00:02:54, H

(10.0.0.1, 239.0.0.1), 00:08:09/00:03:24, flags: T
  Incoming interface: FastEthernet0/13, RPF nbr 10.0.0.13
  Outgoing interface list:
    FastEthernet0/16, Forward/Sparse, 00:08:09/00:02:54, H

(*, 224.0.1.40), 03:09:40/00:02:35, RP 5.5.5.5, flags: SJL
  Incoming interface: FastEthernet0/19, RPF nbr 10.0.0.18
  Outgoing interface list:
    FastEthernet0/16, Forward/Sparse, 01:53:05/00:02:38

SW4#
SW4#sh run | incl multicast
ip multicast-routing 
SW4#sh ip pim rp map
PIM Group-to-RP Mappings

Group(s): 224.0.0.0/4, Static
    RP: 5.5.5.5 (?)
SW4#sh ip pim nei
SW4#sh ip pim neighbor 
PIM Neighbor Table
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
10.0.0.18         FastEthernet0/19         03:05:31/00:01:26 v2    1 / DR S
10.0.0.13         FastEthernet0/13         01:29:16/00:01:39 v2    1 / S
10.0.0.22         FastEthernet0/16         02:12:26/00:01:27 v2    1 / DR S
SW4#
SW4#sh run
!
ip multicast-routing 
!
!
interface FastEthernet0/13
 no switchport
 ip address 10.0.0.14 255.255.255.252
 ip pim sparse-mode
!
interface FastEthernet0/16
 no switchport
 ip address 10.0.0.21 255.255.255.252
 ip pim sparse-mode
!
interface FastEthernet0/19
 no switchport
 ip address 10.0.0.17 255.255.255.252
 ip pim sparse-mode
!         
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
ip pim rp-address 5.5.5.5
!
SW4#     

#SW2#

SW2#sh ip int brief | excl assi
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/2        10.0.0.25       YES manual up                    up      
FastEthernet0/19       10.0.0.22       YES manual up                    up      
SW2#
SW2#sh run int fa0/2
Building configuration...

Current configuration : 106 bytes
!
interface FastEthernet0/2
 no switchport
 ip address 10.0.0.25 255.255.255.252
 ip pim sparse-mode
end

SW2#sh run int fa0/19
Building configuration...

Current configuration : 107 bytes
!
interface FastEthernet0/19
 no switchport
 ip address 10.0.0.22 255.255.255.252
 ip pim sparse-mode
end

SW2#
SW2#sh ip mroute 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.0.0.1), 02:15:16/stopped, RP 5.5.5.5, flags: SJC
  Incoming interface: FastEthernet0/19, RPF nbr 10.0.0.21
  Outgoing interface list:
    FastEthernet0/2, Forward/Sparse, 00:00:35/00:02:46, H

(10.0.0.1, 239.0.0.1), 00:11:51/00:02:58, flags: JT
  Incoming interface: FastEthernet0/19, RPF nbr 10.0.0.21
  Outgoing interface list:
    FastEthernet0/2, Forward/Sparse, 00:00:35/00:02:46, H

(*, 224.0.1.40), 02:15:54/00:02:54, RP 5.5.5.5, flags: SJPCL
  Incoming interface: FastEthernet0/19, RPF nbr 10.0.0.21
  Outgoing interface list: Null

SW2#
SW2#sh run | incl multi
ip multicast-routing 
SW2#sh ip pim rp map
PIM Group-to-RP Mappings

Group(s): 224.0.0.0/4, Static
    RP: 5.5.5.5 (?)
SW2#sh ip pim neigh
PIM Neighbor Table
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
10.0.0.21         FastEthernet0/19         02:15:52/00:01:42 v2    1 / S
SW2#
SW2#sh run
!
ip routing
!
ip multicast-routing 
!         
interface FastEthernet0/2
 no switchport
 ip address 10.0.0.25 255.255.255.252
 ip pim sparse-mode
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
ip pim rp-address 5.5.5.5
!
SW2#   

#R2#

R2#sh ip int brief | excl unassi
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.0.0.26       YES manual up                    up      
Loopback0                  2.2.2.2         YES manual up                    up      
R2#
R2#sh run int lo0
Building configuration...

Current configuration : 63 bytes
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
end

R2#sh run int fa 0/0
Building configuration...

Current configuration : 126 bytes
!
interface FastEthernet0/0
 ip address 10.0.0.26 255.255.255.252
 ip igmp join-group 239.0.0.1
 duplex auto
 speed auto
end

R2#
R2#sh run | incl multicast
R2#
R2#sh run    
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.26 255.255.255.252
 ip igmp join-group 239.0.0.1
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!

R2#    


Redundanz-Test (disablen SW1 fa0/5)


Hier ist noch ein Trace-File vom PIMv2-Register/Register-Stop vom SW1 zum RP (R5), nachdem SW1 fa0/5 zum Redundanz-Test disabled wurde. Danach geht der Multicast-Flow ohne Encapsulation durch.
Damit der Traffic-Flow analog dem Schaubild läuft ist natürlich ein "ip pim spt-threshold infinite" notwendig, um den ShortestPathTree zu vermeiden.

Keine Kommentare:

Kommentar veröffentlichen