Freitag, 20. August 2010

6VPE - BGP PE-CE - Beispielkonfiguration


#Topology#

6VPE is possible with Cisco 1841 Routers (R4,R5,R6) with c1841-adventerprisek9-mz.124-24.T.bin
R1 and R2 are 2610XM

#R1-CE#

R1-CE#sh run
Building configuration...

Current configuration : 1184 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1-CE
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no network-clock-participate slot 1 
no network-clock-participate wic 0 
ip cef
!
!
!
!
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 no ip address
 ipv6 address 1::1/128
 ipv6 enable
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:1::1/64
 ipv6 enable
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
!
router bgp 1
 bgp router-id 1.0.0.1
 bgp log-neighbor-changes
 neighbor 2001:1::2 remote-as 65000
 !
 address-family ipv4
 no neighbor 2001:1::2 activate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv6
 neighbor 2001:1::2 activate
 network 1::1/128
 exit-address-family
!
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

R1-CE#sh ipv6 int brief
FastEthernet0/0            [up/up]
    FE80::20B:FDFF:FEBA:6A40
    2001:1::1
Serial0/0                  [administratively down/down]
FastEthernet0/1            [administratively down/down]
Serial0/1                  [administratively down/down]
Loopback0                  [up/up]
    FE80::20B:FDFF:FEBA:6A40
    1::1
R1-CE#sh ipv6 route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
LC  1::1/128 [0/0]
     via ::, Loopback0
B   2::2/128 [20/0]
     via FE80::21A:2FFF:FE87:5C62, FastEthernet0/0
C   2001:1::/64 [0/0]
     via ::, FastEthernet0/0
L   2001:1::1/128 [0/0]
     via ::, FastEthernet0/0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0
R1-CE#sh ip bgp all
For address family: IPv4 Unicast

For address family: IPv6 Unicast
BGP table version is 17, local router ID is 1.0.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1::1/128         ::                       0         32768 i
*> 2::2/128         2001:1::2                              0 65000 2 i
R1-CE#
R1-CE#ping ipv6 2::2 source lo0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2::2, timeout is 2 seconds:
Packet sent with a source address of 1::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/12 ms
R1-CE#



#R5-PE#

R5-PE#sh run
Building configuration...

Current configuration : 1983 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5-PE
!
boot-start-marker
boot-end-marker
!
vrf definition Customer
 rd 10.0.0.5:100
 !
 address-family ipv6
 route-target export 100:100
 route-target import 100:100
 exit-address-family
!
logging message-counter syslog
logging buffered 16000
!
no aaa new-model
clock timezone MEZ 1
clock summer-time MESZ recurring last Sun Mar 2:00 last Sun Oct 3:00
dot11 syslog
ip source-route
!
!
!
!
ip cef
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
archive
 log config
  hidekeys
! 
!
!
!
!
!
!
!
interface Loopback0
 ip address 1.0.0.5 255.255.255.255
!
interface FastEthernet0/0
 vrf forwarding Customer
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:1::2/64
 ipv6 enable
!
interface FastEthernet0/1
 ip address 10.0.0.1 255.255.255.252
 duplex auto
 speed auto
 mpls ip
!
interface Serial0/0/0
 no ip address
 encapsulation frame-relay IETF
 frame-relay lmi-type cisco
!
router ospf 1
 log-adjacency-changes
 passive-interface default
 no passive-interface FastEthernet0/1
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 65000
 no synchronization
 bgp router-id 1.0.0.5
 bgp log-neighbor-changes
 neighbor 1.0.0.6 remote-as 65000
 neighbor 1.0.0.6 update-source Loopback0
 neighbor 1.0.0.6 send-community extended
 no auto-summary
 !
 address-family vpnv6
  neighbor 1.0.0.6 activate
  neighbor 1.0.0.6 send-community extended
 exit-address-family
 !
 address-family ipv6 vrf Customer
  neighbor 2001:1::1 remote-as 1
  neighbor 2001:1::1 activate
  no synchronization
 exit-address-family
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
end

R5-PE#
R5-PE#sh ipv6 route vrf Customer
IPv6 Routing Table - Customer - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B   1::1/128 [20/0]
     via FE80::20B:FDFF:FEBA:6A40, FastEthernet0/0
B   2::2/128 [200/0]
     via 1.0.0.6%Default-IP-Routing-Table, indirectly connected
C   2001:1::/64 [0/0]
     via FastEthernet0/0, directly connected
L   2001:1::2/128 [0/0]
     via FastEthernet0/0, receive
L   FF00::/8 [0/0]
     via Null0, receive
R5-PE#
R5-PE#sh ip bgp vpnv6 uni vrf Customer
BGP table version is 8, local router ID is 1.0.0.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 10.0.0.5:100 (default for vrf Customer)
*> 1::1/128         2001:1::1                0             0 1 i
*>i2::2/128         ::FFFF:1.0.0.6           0    100      0 2 i
R5-PE#show mpls forward
Local  Outgoing      Prefix            Bytes Label   Outgoing   Next Hop    
Label  Label or VC   or Tunnel Id      Switched      interface              
16     19            1.0.0.6/32        0             Fa0/1      10.0.0.2    
17     Pop Label     1.0.0.4/32        0             Fa0/1      10.0.0.2    
18     Pop Label     10.0.1.0/30       0             Fa0/1      10.0.0.2    
19     No Label      1::1/128[V]       1026          Fa0/0      FE80::20B:FDFF:FEBA:6A40
R5-PE#


#R4-P#

R4-P#sh run
Building configuration...

Current configuration : 981 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4-P
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
memory-size iomem 15
dot11 syslog
ip source-route
!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
archive
 log config
  hidekeys
! 
!
!
!
!
!
!
!
interface Loopback0
 ip address 1.0.0.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.1.2 255.255.255.252
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet0/1
 ip address 10.0.0.2 255.255.255.252
 duplex auto
 speed auto
 mpls ip
!
interface Serial0/0/0
 no ip address
 shutdown
 no fair-queue
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
end

R4-P#
R4-P#show mpls forwarding-table 
Local  Outgoing      Prefix            Bytes Label   Outgoing   Next Hop    
Label  Label or VC   or Tunnel Id      Switched      interface              
18     Pop Label     1.0.0.5/32        43595         Fa0/1      10.0.0.1    
19     Pop Label     1.0.0.6/32        163416        Fa0/0      10.0.1.1    
R4-P#
R4-P#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 3 subnets
O       1.0.0.5 [110/2] via 10.0.0.1, 05:30:57, FastEthernet0/1
C       1.0.0.4 is directly connected, Loopback0
O       1.0.0.6 [110/2] via 10.0.1.1, 11:54:16, FastEthernet0/0
     10.0.0.0/30 is subnetted, 2 subnets
C       10.0.0.0 is directly connected, FastEthernet0/1
C       10.0.1.0 is directly connected, FastEthernet0/0
R4-P#
R4-P#sh ipv6 int brief
FastEthernet0/0            [up/up]
    unassigned
FastEthernet0/1            [up/up]
    unassigned
Serial0/0/0                [administratively down/down]
    unassigned
SSLVPN-VIF0                [up/up]
    unassigned
Loopback0                  [up/up]
    unassigned
R4-P#

#R6-PE#

R6-PE#sh run
Building configuration...

Current configuration : 1864 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6-PE
!
boot-start-marker
boot system flash c1841-adventerprisek9-mz.124-24.T3.bin
boot-end-marker
!
vrf definition Customer
 rd 1.0.0.6:100
 !
 address-family ipv6
 route-target export 100:100
 route-target import 100:100
 exit-address-family
!
logging message-counter syslog
logging buffered 160000
!
no aaa new-model
clock timezone MEZ 1
clock summer-time MESZ recurring last Sun Mar 2:00 last Sun Oct 3:00
dot11 syslog
ip source-route
!
!
!
!
ip cef
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
archive
 log config
  hidekeys
! 
!
!
!
!
!
!
!
interface Loopback0
 ip address 1.0.0.6 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.1.1 255.255.255.252
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet0/1
 vrf forwarding Customer
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:2::2/64
 ipv6 enable
!
interface Serial0/0/0
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 65000
 no synchronization
 bgp router-id 1.0.0.6
 bgp log-neighbor-changes
 neighbor 1.0.0.5 remote-as 65000
 neighbor 1.0.0.5 update-source Loopback0
 neighbor 1.0.0.5 send-community extended
 no auto-summary
 !
 address-family vpnv6
  neighbor 1.0.0.5 activate
  neighbor 1.0.0.5 send-community extended
 exit-address-family
 !
 address-family ipv6 vrf Customer
  neighbor 2001:2::1 remote-as 2
  neighbor 2001:2::1 activate
  no synchronization
 exit-address-family
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
end

R6-PE#
R6-PE#sh ipv6 route vrf Customer
IPv6 Routing Table - Customer - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B   1::1/128 [200/0]
     via 1.0.0.5%Default-IP-Routing-Table, indirectly connected
B   2::2/128 [20/0]
     via FE80::20B:FDFF:FEF9:2101, FastEthernet0/1
C   2001:2::/64 [0/0]
     via FastEthernet0/1, directly connected
L   2001:2::2/128 [0/0]
     via FastEthernet0/1, receive
L   FF00::/8 [0/0]
     via Null0, receive
R6-PE#
R6-PE#sh ip bgp vpnv6 uni vrf Customer
BGP table version is 12, local router ID is 1.0.0.6
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1.0.0.6:100 (default for vrf Customer)
*>i1::1/128         ::FFFF:1.0.0.5           0    100      0 1 i
*> 2::2/128         2001:2::1                0             0 2 i
R6-PE#sh mpls forward
Local  Outgoing      Prefix            Bytes Label   Outgoing   Next Hop    
Label  Label or VC   or Tunnel Id      Switched      interface              
19     No Label      2::2/128[V]       1026          Fa0/1      FE80::20B:FDFF:FEF9:2101
21     18            1.0.0.5/32        0             Fa0/0      10.0.1.2    
22     Pop Label     10.0.0.0/30       0             Fa0/0      10.0.1.2    
23     Pop Label     1.0.0.4/32        0             Fa0/0      10.0.1.2    
R6-PE#


#R2-CE#

R2-CE#sh run
Building configuration...

Current configuration : 1075 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2-CE
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no network-clock-participate slot 1 
no network-clock-participate wic 0 
ip cef
!
!
!
!
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 no ip address
 ipv6 address 2::2/128
 ipv6 enable
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:2::1/64
 ipv6 enable
!
router bgp 2
 bgp router-id 1.0.0.2
 bgp log-neighbor-changes
 neighbor 2001:2::2 remote-as 65000
 !
 address-family ipv4
 no neighbor 2001:2::2 activate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv6
 neighbor 2001:2::2 activate
 network 2::2/128
 exit-address-family
!
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

R2-CE#sh ipv6 int brief
FastEthernet0/0            [administratively down/down]
FastEthernet0/1            [up/up]
    FE80::20B:FDFF:FEF9:2101
    2001:2::1
Loopback0                  [up/up]
    FE80::20B:FDFF:FEF9:2100
    2::2
R2-CE#sh ipv6 route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B   1::1/128 [20/0]
     via FE80::226:CBFF:FE2E:41AF, FastEthernet0/1
LC  2::2/128 [0/0]
     via ::, Loopback0
C   2001:2::/64 [0/0]
     via ::, FastEthernet0/1
L   2001:2::1/128 [0/0]
     via ::, FastEthernet0/1
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0
R2-CE#ping 2::2 source lo0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2::2, timeout is 2 seconds:
Packet sent with a source address of 2::2
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/1/4 ms
R2-CE#

R4,R5,R6 = c1841
R1,R2 = c2610xm

Keine Kommentare:

Kommentar veröffentlichen